IrisBG Batch Jobs and email settings

  • DanielMosquin

    #741

    Trying to get this working, but ran into a failure with the email test. My first question is: should this be installed on the server hosting the database? Or can it run from my desktop?

    Second question, assuming it can be run from my desktop: what are the chances of finding a way to push out a more detailed error message than “Failure sending mail” so I can troubleshoot? It attempts for about a minute, then fails.

    Havard

    #743

    If you are planning to run the job at fixed intervals via scheduler, I would recommend setting it up on a server. However, it depends a bit on the type of job. Keep in mind that the IrisBG desktop software needs to be installed on the same machine.

    The email setup parameters are very similar (often identical) to what a normal email client would use. A lot of scenarios will unfortunatly just return “no success” without any further details.

    DanielMosquin

    #744

    Good to know re that it should work from either server or desktop (was initially trying on desktop to test, just wanted to confirm that that wouldn’t be an issue)

    Yes, I am in one of those scenarios. Using same setup as my email client, and also opened up permissions on firewall, but no go. I’ll try on different machines next.

    DanielMosquin

    #745

    Same error (presumably) from a different desktop. I’ll try from the server another day.

    DanielMosquin

    #746

    Having trouble with this. I’ve attempted it from 2 different desktops (home and work) with different firewall systems as well as the server hosting the database. From my work desktop and the server hosting the database, I’ve also attempted it with my work email and Google email accounts / smtp services on each, and it has failed every time. The only difference that I’ve noticed is that attempts to use Google’s smtp service fails quickly while my work’s smtp service looks like it fails on a timeout.

    Havard

    #747

    Sorry to hear that you still are having difficulties.

    Please note that the SMTP port for google might not be 25 (See link below).

    One combination that should work:

    Host: smtp.gmail.com
    Port : 465
    Requires : SSL
    User name : Your GMail account
    Password: Your GMail password

    https://support.google.com/a/answer/176600?hl=en

    DanielMosquin

    #748

    I’ve been using port 465 / SSL for both my Google and UBC tests, as that is also what we use at my university: https://it.ubc.ca/services/email-voice-internet/ubc-faculty-staff-email-fasmail/fasmail-setup-documents

    Havard

    #750

    This was a slightly more interesting story than expected :/

    First, we did identfy one technical issue with the email test when SSL encryption is enabled. This has been fixed and you can download a new release. The actual email notification part will work if the settings are correct, but I would recommned getting the latest release so that you can test the settings.

    When testing with a GMail account, we found conflicting (vague) information about what the correct setup should be.
    The recommended settings are:
    SMTP Server Host: smtp.gmail.com
    SMTP Port: 587 (NOT 465!!)
    User Name : mygmailaccountname@gmail.com
    Password: mygmailpassword

    Tips:
    – Use the same domain (preferably same account) for “sender” (some services may block the email if sender is from an external domain/different than account).
    – Make sure your gmail account have a strong password. I have seen claims that gmail accounts with weak passwords will block logins from external applications.
    – Enable “Allow less secure apps” in the Gmail Security settings (see attachment). This was the final stumbling block which took some time to figure out 🙂

    • This reply was modified 3 years ago by  Havard.
    Attachments:
    You must be logged in to view attached files.

    DanielMosquin

    #757

    More interesting story than expected, eh? In other words, not just a user not following the instructions error. 😈

    I have it working with Gmail with the settings you’ve suggested. For my internal university SMTP service, still no go, but at least I can contact them and ask since I have it working on another platform.

    Havard

    #759

    Daniel – I expected that you had discovered an issue with the SMTP + SSL settings – nothing less from you sir :mrgreen:

    Most of the time was spent figuring out why GMail responded with Authentication Required message and did not work over port 465.

    Did you try port 587 for the university service?

    DanielMosquin

    #760

    My initial test with 587 on the university service failed, but I didn’t pursue it (and may have misconfigured it). I’ll give it another go before contacting the IT staff responsible for mail.

    In the meantime, configuring the first task as a test. I’ve a few suggestions, but will start a new thread so that this one stays on the topic of configuring email.

    DanielMosquin

    #763

    Further attempts with the university service failed, I’ve submitted a ticket with them.

    DanielMosquin

    #781

    A not unexpected response from our IT support: “Are you able to generate any error logs from the desktop application? It’s hard to tell where it’s failing if no error code is returned (incorrect login, server unreachable, etc.) All I can tell you with certainty is the server name, login information and ports are correct.”

    Havard

    #782

    The details returned from the SMTP call is very basic . However, there are a number of diagnostic tools available that should be able to do a much better job.

    Have not tried this myself, but the SMTP Diag Tool from AdminKit should give some insight into the issue.
    http://www.adminkit.net/smtp_diag_tool.aspx

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.